Debian Repository kernel 2.6.37 e 2.6.37-ck1

 

Nel mio nuovo Repository si trovano i kernel 2.6.37 sia per architettura i386 che amd64, inoltre si trovano le stesse versioni del kernel col ck1, ossia patchati Con Kolivas. Da aggiungere ad /etc/apt/sources.list il seguente indirizzo:

 

#### Edmond's repository
deb https://www.edmondweblog.com/repo/ binary/

 

Consiglio:

Per chi ha i driver Nvidia installati, almeno a me succede questo, consiglio dopo aver installato il nuovo kernel, quindi prima di riavviare, di modificare il file /etc/X11/xorg.conf, e sostituire sotto Device la voce Nvidia con nv, questo per evitare che avviando il nuovo kernel, il server X, si pianti e renda difficile il passaggio in tty1 (Ctrl-Alt-F1), dopo di chè si possono installare i driver Nvidia, col solito metodo del :

Ctrl-Alt-F1

# /etc/init.d/gdm3 stop

andare nel percorso dei driver Nvidia ufficiali:

# ./NVIDIA-Linux-x86_64-260.19.21.run

 

enjoy 😉

Autore: Franco Conidi aka edmond

Senior System Integrator, Network Administrator, Sys Admin Linux, Linux User, Consulente Informatico.

16 pensieri riguardo “Debian Repository kernel 2.6.37 e 2.6.37-ck1”

  1. Con il DKMS, non c'è bisogno di fare quello, vero?

    Ciao e buona giornata! 🙂

    Mokmo

  2. se ti riferisci al consiglio per chi ha i driver nvidia (ati non saprei) ti posso dire

    che io ho il DKMS ma il problema del passare in tty1 è reale. I driver Nvidia

    vanno reinstallati 😉

  3. ciao, intanto grazie!
    vale lo stesso per me che ho installato i driver nvidia da module assistant?

  4. @lucors

    sinceramente non saprei, ma ho il sospetto di si, comunque provare non costa

    nulla al limite torni al kernel precedente.

  5. ciao,
    allora, ho provato ed i risultati sono i seguenti:
    – funziona tutto anche senza fare la correzione al xorg.conf (non so se sia determinato dal fatto che ho messo i driver nvidia da m-a)
    -stranamente, una volta caricato con il molto veloce 2.6.37ck1, sul conky non viene rilevata la temperatura della CPU!boh…
    ciao e grazie

  6. @lucors

    ti chiedo di essere più preciso per quanto riguarda i driver nvidia,  e cioè, tu una volta installato il kernel ck1,

    NON hai modificato xorg.conf ed al riavvio con nuovo kernel sei riuscito a passare in tty1 senza problemi di

    sfarfallio, oppure ti si è avviato il server X (NON ci credo)).  Io ho appena fatto un test su LMDE con gli nvidia installati

    con m-a ed ho avuto lo stesso problema che ho elencato nel post.

    ciao edmond

  7. eccomi! ho controllato: i miei driver sono 195.36.31, installati con m-a. Installato il kernel avevo modificato come suggerivi tu, ma al riavvio non risultava attiva la scheda grafica; quindi ho rimesso "nvidia" e tutto e ritornato a posto. ripeto che l'unica anomalia è conky che non mi rileva la temperatura della CPU. i passaggi a tty1 (e successive) non dà nessun problema… anzi, prima lo schermo sfarfallava quando mi si connetteva dropbox ed ora non lo fà più (!!!!). Per ulteriore info ti specifico che il mio pc è un dell xps 1330m con nvidia g8400… ciao, grazie ancora, mi spiace averti "spiazzato";-)

  8. ok, grazie per la precisazione, quindi mi stai dicendo che non hai reinstallato i driver nvidia col nuovo kernel.?

  9. figurati… grazie a te! non ho reinstallato nulla; in effetti il dkms ha funzionato:-)

  10. Installato su Mint Debian Edition. Tutto ok tranne i driver proprietaty ATI. Fallisce il DKMS sia dai pacchetti deb sia usando l'installer ATI stesso.
    /var/lib/dkms/fglrx/8.801/build; sh make.sh –nohints –uname_r=2.6.37-ck1-edm –norootcheck……(bad exit status: 1)
    0
    0
    [Error] Kernel Module : Failed to build fglrx-8.801 with DKMS
    [Error] Kernel Module : Removing fglrx-8.801 from DKMS
     

  11. altri che hanno usato questo kernel non hanno avuto questo problema, comunque prova questo su LMDE

  12. Grazie Edmond, ma nel repository che mi segnali c' è solo la versione a 32 bit mentre il mio sistema è a 64.
    Comunque per ora me la cavo coi driver open source che vanno benissimo per il 2D (il notebook lo uso per lavoro e non ho bisogno di nessuna funzione 3D particolare)

  13.  
    Ciao
     
    sto "edmondizzando" la mia Squeeze e quindi ho installato il tuo kernel: devo davvero ringraziarti, il miglioramento si vede ad occhio nudo. 
    Tra l'altro il pacchetto nvidia-kernel-dkms precedentemente installato ha funzionato alla grande, al successivo riavvio X è partito come un treno! 😀
     
    Che dire, grazie ancora! 🙂
     
    Fabio

  14. @Fabio

    grazie a te per la segnalazione, e prossimamente aggiornerò i kernel con qualche modifica,

    sopratutto per schede Ati 😉

  15. passavo di qui per caso.
    volevo dire a lucors che io ho ricompilato il vanilla 2.6.37 su debian squeeze e mi fa lo scherzetto della temperatura.
    cioè con il kernel vecchio avevo temp1 temp2 tzs1 tzs0. con   il 2.6.37 solo 2 temp1 e un temp2 senza le termal zone.
    che sia un problema insito nel kerrnel 2.6.37??????

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.